Loading...

Supported Browsers

For security reasons we always recommend you operate an update-to-date browser, using the latest releases wherever possible.

However, for the purposes of backward compatibility, we support the following browsers for the frontend login process.

Software Version
Internet Explorer >= 9
Firefox >= 31
Chrome >= 34

For the administration console there is a higher minimum requirement.

Software Version
Internet Explorer >= 10
Firefox >= 44
Chrome >= 49

Previous Article

System Requirements

Next Article

Manual Installation

We're happy to talk

Our offices are open 8.30am - 7pm GMT, Monday to Friday - but you can always contact us via email. When we receive your email during opening hours, we aim to respond within 30 minutes or less. Should your email reach us out of hours, we will contact you when the office re-opens.

You can contact us using live chat